Praca z CASPOC - podstawy

<br>Click to close the image

 

 

1 Rozpoczynamy pracę z CASPOC

W kolejnych rozdziałach opisano tworzenie schematu i symulację działania prostego konwertera w programie CASPOC. Po zrealizowaniu czynności wymienionych w treści rozdziałów (około 30 minut), opanujesz podstawy tworzenia i symulacji pracy własnego projektu, przy użyciu edytora schematów i symulatora programu.

 

1.1 Uruchomienie programu

Uruchom program CASPOC wybierając z menu Start/Programy/Caspoc/CASPOC (lub Start/Wszystkie programy/Caspoc/CASPOC).

<br>Click to close the image

Na ekranie ukaże się edytor schematów. Korzystając z niego, będziesz mógł stworzyć własny projekt.

<br>Click to close the image

 

2 Tworzenie schematu

W kolejnych punktach rozdziału opisano krok po kroku czynności przy tworzeniu schematu. Postępuj zgodnie ze wskazówkami. Ilustracje przedstawiają poszczególne etapy tworzenia schematu.

2.1 Schemat obwodu elektrycznego

W tym punkcie omówiono, w jaki sposób wprowadzić do arkusza roboczego i połączyć ze sobą elementy schematu elektrycznego przedstawionego poniżej.

<br>Click to close the image

 

Zacznij od umieszczenia elementów schematu na arkuszu roboczym. Z rozwijanej listy po lewej stronie ekranu wybierz sterowane napięciowo źródło "B". Ustaw kursor na nazwie źródła, kliknij lewym klawiszem myszy i przenieś kursor na odpowiednie miejsce arkusza roboczego. Ponowne kliknięcie lewym klawiszem myszy umieszcza wybrany element na arkuszu roboczym.

<br>Click to close the image

Jeżeli na arkuszu roboczym umieścisz pierwszy element schematu, to pojawi się okno dialogowe z propozycją automatycznego nadania jednemu z zacisków elementu etykiety 'Ground' ('masa') lub '0'. Zaleca się wybranie [Yes].

<br>Click to close the image

Podczas symulacji 'Ground' jest punktem odniesienia dla pomiaru wszystkich wartości napięć. W razie potrzeby można później zmienić punkt odniesienia.

 

<br>Click to close the image

Najedź kursorem na wstawiony element i kliknij prawym klawiszem myszy, co wywoła poniższe okno.

<br>Click to close the image

 

Pozostaw nazwę elementu B1 i ustaw jego kierunek na 180°. Aby obrócić element zaznacz kursorem pole 180°. Wskazany kąt podaje kierunek przepływu prądu przez element zgodnie z poniższym rysunkiem.

<br>Click to close the image

Po naciśnięciu [OK], i wybraniu [Yes] w oknie dialogowym automatycznego przyporządkowania punktu '0', zauważysz, że na schemacie element został obrócony.

<br>Click to close the image

Następnie umieść na schemacie diodę. Wybierz element "D" z listy (jak wskazuje poniższa ilustracja) i przenieś go na arkusz roboczy obok elementu "B1".

<br>Click to close the image

Możesz edytować właściwości diody ustawiając kursor na jej symbolu i klikając prawym klawiszem myszy. W polu Name pozostaw nazwę diody " D1" a w Rotate zaznacz kierunek diody "270°". Pole Value dotyczy typu diody. W tym wypadku pozostaw standardowy napis "Diode". Zamknij okno klikając [OK].

<br>Click to close the image

Jeżeli na arkuszu roboczym wybierzesz dowolny element, klikając na niego lewym klawiszem myszy, to będzie on narysowany linią przerywaną.

<br>Click to close the image

Jeśli ustawisz kursor na symbolu diody, naciśniesz i przytrzymasz lewy klawisz myszy, to ruchem myszy możesz przesuwać diodę po arkuszu roboczym, aż znajdzie się w żądanym położeniu. Zwolnij naciśniety klawisz. W taki sam sposób jak D1 wstaw do arkusza kolejną diodę, wybierając "D" z rozwijanej listy po lewej stronie ekranu. Dioda D2 będzie miała taki kierunek, jak ostatnio wstawiony do arkusza element. W poznany sposób umieść na właściwym miejscu diodę D2 a po wykonaniu tej czynności wstaw i rozmieść diody D3 i D4. W następnej kolejności wstaw do arkusza cewkę L1, wybierając L na liście elementów.

 

<br>Click to close the image

Edytuj właściwości cewki L1, ustawiając kursor na jej symbolu i klikając prawym klawiszem myszy.

<br>Click to close the image

W polu Name nadaj cewce nazwę "Lfilter" , w polu Value wpisz wartość indukcyjności "50mH", a w polu Rotate kierunek "180°".

Pole "Value" oprócz samych liczb wyrażających wartość danej wielkości w jednostkach podstawowych, akceptuje także wpisy według poniższego zestawienia:

m 1e-3 u 1e-6

k 1e3 n 1e-9

Meg 1e6 p 1e-12

Zamknij okno, klikając [OK].

W następnej kolejności umieść na arkuszu kondensator "C".

<br>Click to close the image

Edytuj właściwości kondensatora:

<br>Click to close the image

Nadaj mu nazwę "Cload", wartość "1mF" i kierunek "90°".

Rezystor "R" umieść na arkuszu w taki sposób, jak poprzednie elementy. Nadaj mu wartość 6 omów i nazwę "Rload".

Następny krok to wykonanie połączeń pomiędzy elementami. Rysowanie linii połączenia zacznij od ustawienia kursora na punkcie węzłowym (końcówka elementu zaznaczona czarną kropką). Naciśnij lewy klawisz myszy i trzymając go, przeciągnij kursor po arkuszu do następnego punktu węzłowego, rysując linię połączenia. Zwolnij klawisz myszy po ustawieniu kursora na wybranym punkcie węzłowym. Kreślenie każdej nowej linii można rozpocząć tylko od punktu węzłowego.

<br>Click to close the image

Jeśli omyłkowo umieściłeś na arkuszu niewłaściwy element, lub wykonałeś nieprawidłowe połączenie, to możesz dokonać poprawki. Kliknij lewym klawiszem myszy na element lub połączenie przeznaczone do usunięcia (ale nie na punkt węzłowy), lub ustaw kursor obok elementu (połączenia) i trzymając naciśniety lewy klawisz myszy obrysuj element. Zwolnij klawisz myszy. Przeznaczony do usunięcia fragment schematu będzie zaznaczony linią przerywaną. Naciśnij klawisz [Delete]. Zaznaczony fragment schematu zostanie usunięty.

Aby usunąć punkt węzłowy, lub bardzo krótką linię, ustaw na nich kursor i kliknij prawym klawiszem myszy. W pojawiającym się oknie dialogowym kliknij na [Delete node]. Linia zostanie usunięta.

Po wykonaniu liniami wszystkich połączeń na arkuszu roboczym znajduje się przedstawiony poniżej schemat.

<br>Click to close the image

Teraz musisz wybrać punkt węzłowy, któremu nadasz etykietę "GROUND" lub "0". Podczas symulacji 'GROUND' jest punktem odniesienia dla pomiaru wszystkich wartości napięć. W przedstawionym schemacie będzie to ostatni, dolny węzeł z prawej strony. Ustaw na nim kursor i kliknij prawym klawiszem myszy. Otworzy się okno dialogowe, w którym, dla Label wpisz "ground" (pole Label dopuszcza zapis "ground" lub "0" jako definicję punktu odniesienia).

<br>Click to close the image

Kliknij na [OK]. Na schemacie etykieta "GROUND" występuje teraz dwukrotnie. Należy usunąć "GROUND" z punktu węzłowego źródła B1, jako niewłaściwy w tym przypadku punkt odniesienia. Ustaw na nim kursor i kliknij prawym klawiszem myszy. Gdy pojawi się okno dialogowe Label z wpisem "GROUND" naciśnij klawisz [DELETE] na klawiaturze a następnie kliknij [OK] w oknie dialogowym. Etykieta "GROUND" przy węźle źródła B1 zostanie usunięta.

Zdefiniuj także węzeł (ostatni, górny z prawej strony), na którym będziesz obserwował wyniki symulacji. Ustaw na nim kursor i kliknij prawym klawiszem myszy. Otworzy się okno dialogowe, w którym, dla Label wpisz "out". Kliknij [OK].

Po wykonaniu powyższych czynności ostatecznie na ekranie pojawi się obraz przedstawiony poniżej.

<br>Click to close the image

 

2.2 Wstawianie bloków

Schemat ideowy jest gotowy. Teraz trzeba umieścić na arkuszu roboczym bloki funkcjonalne, dzięki którym będzie możliwa symulacja pracy układu. W skład zestawu bloków definiujących napięcie źródła B1 wchodzą: blok "TIME" (czas symulacji w sekundach) i blok "SIGNAL" (generator sygnału), wytwarzający napięcie sinusoidalne o amplitudzie 25 V. Wymienione bloki znajdują się na liście elementów i bloków, rozwijanej z lewej strony arkusza roboczego.

Z rozwijanej listy wybierz blok "TIME" i poznaną dla wstawiania elementów metodą umieść w odpowiednim miejscu arkusza roboczego (patrz rysunek poniżej).

<br>Click to close the image

 

Edytuj właściwości bloku "TIME", ustawiając na nim kursor i klikając prawym klawiszem myszy. We właściwościach bloku, w polu Name wpisz nazwę "t". Oprócz nazwy bloku, będzie to także etykieta punktu węzłowego wyjścia bloku. Kliknij na [OK], aby zamknąć okno dialogowe. Węzeł na wyjściu bloku "TIME" otrzymał etykietę "T", zamiast poprzedniej "TIME1".

<br>Click to close the image

Po bloku "TIME", wstaw do arkusza blok "SIGNAL" w sposób analogiczny jak ten poprzedni.

 

<br>Click to close the image

 

Należy teraz nadać etykiety (wartości) dla pięciu wejść bloku "SIGNAL" w analogiczny sposób jak nadawanie etykiet punktom węzłowym schematu. Wybierz kursorem żądany węzeł wejścia bloku, kliknij prawym klawiszem myszy i w oknie dialogowym wpisz odpowiednią dla danego wejścia wartość według poniższego wyszczególnienia:

INPUT VALUE

DC voltage DC 0

Amplitude AC 25

Frequency F 50

Phase Phase 0

Duty cycle d 0

Musisz też zdefiniować parametry bloku "SIGNAL". Najedź kursorem na blok i kliknij prawym klawiszem myszy, wywołując poniższe okno dialogowe.

<br>Click to close the image

Parametr "p3" określa kształt generowanego sygnału - wpisz w pole obok wartość "3" (sinusoidalny). W pole Name wpisz nazwę "Vin". Kliknij [OK].

<br>Click to close the image

Zestaw bloków jest gotowy. Teraz musisz utworzyć połączenie pomiędzy schematem blokowym a schematem obwodu elektrycznego (połączyć wyjście VIN bloku "SIGNAL" z wejściem elementu B1). Ustaw kursor na węźle VIN i trzymając naciśniety lewy klawisz myszy narysuj linię łączącą ten węzeł z węzłem wejścia elementu B1. Zwolnij klawisz myszy.

Końcową czynnością jest umieszczenie na arkuszu roboczym bloku "SCOPE" (oscyloskop), służącego do obserwacji wyników symulacji. Z rozwijanej listy wybierz blok "SCOPE" i umieść go w takim miejscu arkusza roboczego, aby przyłączyć wejście "SCOPE" do węzła "OUT".

<br>Click to close the image

2.3 Parametry symulacji

Schemat posiada już wszystkie dodatki, niezbędne do przeprowadzenia symulacji. Należy tylko określić parametry symulacji: krok symulacji, czas i dokładność punktowego odwzorowania wyników symulacji na wykresie. Z menu wybierz Simulation/Simulation Parameters.

<br>Click to close the image

W tym przykładzie czas (Tscreen) ustaw na "100ms", krok symulacji (dt) na "100ms" a dokładność punktowego odwzorowania wyników symulacji na wykresie (Show each)- co "1" krok symulacji. Zaznacz pole obok

[x]Wait After Screen

aby symulacja została zatrzymana automatycznie po pierwszych 100 ms a jej wynik w postaci obrazu nieruchomego przedstawiony na ekranie oscyloskopu "SCOPE".

<br>Click to close the image

Naciśnij [OK], aby zamknąć okno dialogowe ustawiania parametrów symulacji.

2.4 Zapisywanie schematu

Gdy schemat jest ukończony można zapisać go w pliku na dysku. Z menu wybierz File/Save As.

<br>Click to close the image

W odpowiednie pole okna dialogowego wpisz nazwę pliku, na przykład "Example.csi"oraz określ miejsce zapisu pliku na dysku. Rozszerzenie nazwy pliku ".csi" stosowane jest do zapisywania schematów. Kliknij [Zapisz].

 

3 Symulacja

Symulacja odbywa się w czasie edycji schematu a jej wyniki przedstawiane za pomocą bloku "SCOPE" ( "Oscyloskop"). Oscyloskop posiada funkcję automatycznego dopasowania skali na ekranie do wartości parametrów przedstawianych funkcji. Dopasowanie zachodzi za każdym razem, gdy kontynuujesz symulację.

3.1 Start symulacji

<br>Click to close the image

Aby rozpocząć symulację wybierz Simulation/Start simulation.

Symulacja rozpocznie się - na ekranie oscyloskopu będzie kreślona (w miniaturowej formie, określonej rozmiarem ekranu oscyloskopu na arkuszu roboczym) charakterystyka przebiegu napięcia w funkcji czasu.

<br>Click to close the image

Aby obejrzeć wyniki symulacji należy ustawić kursor na bloku "SCOPE" i kliknąć prawym klawiszem myszy. Spowoduje to powiększenie okna oscyloskopu i umożliwi obserwację przebiegu napięcia występującego na wyjściu OUT badanego układu w czasie pierwszego cyklu symulacji.

<br>Click to close the image

Możesz prześledzić wartość napięcia w poszczególnych punktach charakterystyki (z minimalnym krokiem ustawionym w oknie "Simulation Parameters" jako dokładność punktowego odwzorowania wyników symulacji na wykresie (Show each) - w tym przykładzie: co 1 krok symulacji dt = 100ms), klikając na strzałki znajdujące się w górnej części powiększonego okna oscyloskopu 'SCOPE'. Po wykresie zacznie przemieszczać się "krzyżyk", a poniżej wykresu pojawią się na liście odpowiadające jego aktualnemu położeniu współrzędne - wartości czasu i napięcia.

 

3.2 Kontynuacja symulacji

Aby kontynuować symulację należy nacisnąć klawisz [ENTER] lub wybrać Simulation/Continue simulation. W dowolnej chwili możesz przerwać symulację, dokonać zmian w schemacie i kontynuować symulację naciskając [ENTER].

 

 

4 Eksport i drukowanie

W rozdziale omówiono eksport wyników symulacji i schematu do edytora tekstu oraz drukowanie schematu.

4.1 Eksport wyników symulacji do edytora tekstu

Wyniki symulacji możesz skopiować do Schowka a następnie umieścić w dowolnym edytorze tekstu lub programie graficznym. Przed kopiowaniem należy ustawić białe tło rysunku symulacji - w oknie "SCOPE" wybrać Options/Background Color i po zaznaczeniu koloru białego nacisnąć [OK]. Takie rozwiązanie zapobiegnie w przyszłości nadmiernemu zużyciu tuszu lub tonera podczas drukowania dokumentu.

Rozpocznij symulację. Po jej zakończeniu powiększ obraz wyników symulacji do rozmiarów ekranu i naciśnij na klawiaturze klawisz "PrintScreen". Następnie otwórz edytor tekstu lub program graficzny i z menu wybierz Edycja/Wklej (Edit/Paste). Wyniki symulacji zostaną wklejone do dokumentu jako obraz.

 

4.2 Eksport schematu do edytora tekstu

Możesz umieścić schemat elektryczny w dokumencie tekstowym, eksportując go najpierw do pliku o formacie "Rozszerzony Metaplik..." (*.EMF). Z pliku o takim formacie obraz może być importowany do dokumentu tekstowego. Aby wyeksportować schemat do " *.emf " wybierz File/Export EMF.

<br>Click to close the image

 

Na ekranie pojawi się okno dialogowe " Zapisywanie jako" ("Save As").

<br>Click to close the image

W oknie dialogowym wybierz katalog, w którym chcesz zapisać eksportowany plik i nadaj plikowi nazwę (z rozszerzeniem *.emf). Naciśnij Save, w celu zapisania pliku. Otwórz edytor tekstu i zaimportuj obraz z zapisanego pliku. Dla przykładu: w Microsoft Word wybierz z menu Wstaw/Obraz/Z pliku... W oknie dialogowym ustaw Pliki Typu jako "Enhanced Meta File" ("Rozszerzony metaplik..."), wybierz wyeksportowany schemat (*.emf) i kliknij [Wstaw]. Schemat zostanie wklejony do dokumentu jako obraz.

<br>Click to close the image

Jeżeli posiadany edytor tekstu nie czyta plików typu " Rozszerzony metaplik..." (*.emf), to możesz umieścić w nim schemat elektryczny, korzystając ze schowka. W tym celu w czasie edycji schematu naciśnij na klawiaturze klawisz "PrintScreen". Otwórz edytor tekstu i wybierz Edycja/Wklej. Do edytora tekstu zostanie wklejony jako obraz widok ekranu z wyświetlanym przed naciśnięciem "PrintScreen" schematem (lub jego częścią).

 

4.3 Drukowanie schematu

Aby wydrukować schemat wybierz File/Print.

<br>Click to close the image

Po ustawieniu w oknie dialogowym parametrów wydruku, wybierz [Drukuj]. Schemat zostanie wydrukowany.

Jeśli schemat jest zbyt mały, to możesz go powiększyć do żądanych rozmiarów, korzystając z menu View/Zoom. Po kliknięciu na odpowiedni współczynnik powiększenia wybierz z menu File/Print, a następnie [Drukuj].

<br>Click to close the image
© 2018 CASPOC, All rights reserved. Home   |   Terms and Conditions   |   Legal   |   Export Compliance   |   Privacy Policy   |   Site Map